(Contourné) Problème d'upload avec Arduino mini V04

Les cartes Arduino, les platines

(Contourné) Problème d'upload avec Arduino mini V04

Message non lude thriller91 » Lun 13 Fév 2012 12:40

Bonjour,

on essaye en vain d'uploader le programme blink sur notre Arduino mini v04. On utilise un adaptateur USB2Serial light.
Le message d'erreur était le suivant avant qu'on lise ce topic:
Code: Tout sélectionner
avrdude: stk500_getsync(): not in sync: resp=0x1c


Nous avons réussit à obtenir une erreur plus évoluée:
Code: Tout sélectionner
avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "I:\Documents and
Settings\Administrateur\Bureau\arduino\arduino-1.0-windows\arduino-1.0\hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : \\.\COM3
         Using Programmer              : stk500v1
         Overriding Baud Rate          : 115200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [10]
         AVR Part                      : ATMEGA328P
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PC2
         RESET disposition             : dedicated
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page                     
 Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW 
ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- -----
---------
           eeprom        65    20     4    0 no       1024    4      0  3600  3600
0xff 0xff
                                  Block Poll               Page                     
 Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW 
ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- -----
---------
           flash         65     6   128    0 yes     32768  128    256  4500  4500
0xff 0xff
                                  Block Poll               Page                     
 Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW 
ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- -----
---------
           lfuse          0     0     0    0 no          1    0      0  4500  4500
0x00 0x00
                                  Block Poll               Page                     
 Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW 
ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- -----
---------
           hfuse          0     0     0    0 no          1    0      0  4500  4500
0x00 0x00
                                  Block Poll               Page                     
 Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW 
ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- -----
---------
           efuse          0     0     0    0 no          1    0      0  4500  4500
0x00 0x00
                                  Block Poll               Page                     
 Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW 
ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- -----
---------
           lock           0     0     0    0 no          1    0      0  4500  4500
0x00 0x00
                                  Block Poll               Page                     
 Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW 
ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- -----
---------
           calibration    0     0     0    0 no          1    0      0     0     0
0x00 0x00
                                  Block Poll               Page                     
 Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW 
ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- -----
---------
           signature      0     0     0    0 no          3    0      0     0     0
0x00 0x00

         Programmer Type : STK500
         Description     : Atmel STK500 Version 1.x firmware
avrdude: Send: A [41] . [80]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [03]
avrdude: Recv: . [10]
avrdude: Send: A [41] . [81]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [03]
avrdude: Recv: . [10]
avrdude: Send: A [41] . [82]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [03]
avrdude: Recv: . [10]
avrdude: Send: A [41] . [98]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [03]
avrdude: Recv: . [10]
         Hardware Version: 3
         Firmware Version: 3.3
avrdude: Send: A [41] . [84]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [03]
avrdude: Recv: . [10]
avrdude: Send: A [41] . [85]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [03]
avrdude: Recv: . [10]
avrdude: Send: A [41] . [86]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [03]
avrdude: Recv: . [10]
avrdude: Send: A [41] . [87]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [03]
avrdude: Recv: . [10]
avrdude: Send: A [41] . [89]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [03]
avrdude: Recv: . [10]
         Vtarget         : 0.3 V
         Varef           : 0.3 V
         Oscillator      : 28.800 kHz
         SCK period      : 3.3 us

avrdude: Send: A [41] . [81]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [03]
avrdude: Recv: . [10]
avrdude: Send: A [41] . [82]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [03]
avrdude: Recv: . [10]
avrdude: Send: B [42] . [86] . [00] . [00] . [01] . [01] . [01] . [01] . [03] . [ff]
. [ff] . [ff] . [ff] . [00] . [80] . [04] . [00] . [00] . [00] . [80] . [00]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [10]
avrdude: Send: E [45] . [05] . [04] . [d7] . [c2] . [00]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [10]
avrdude: Send: P [50]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [10]
avrdude: AVR device initialized and ready to accept instructions

Reading | avrdude: Send: V [56] 0 [30] . [00] . [00] . [00]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [00]
avrdude: Recv: . [10]
avrdude: Send: V [56] 0 [30] . [00] . [01] . [00]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [00]
avrdude: Recv: . [10]
################avrdude: Send: V [56] 0 [30] . [00] . [02] . [00]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [00]
avrdude: Recv: . [10]
################################## | 100% 0.02s

avrdude: Device signature = 0x000000
avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.

avrdude: Send: Q [51]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [10]

avrdude done.  Thank you.


La transmission sur la carte semble instable, puisque qu'on obtient la première erreur 3 fois 4. Notre branchement est très simple, on croise RX et TX, on branche l'alimentation +5V et Gnd. Et le reset est branché sur le reset de l'adaptateur.

Merci pour votre aide.
Dernière édition par thriller91 le Lun 20 Fév 2012 17:03, édité 1 fois.
thriller91
 
Messages: 3
Inscription: Lun 13 Fév 2012 12:16

Re: Problème d'upload avec Arduino mini V04

Message non lude Lionel » Lun 13 Fév 2012 15:00

Bonjour,

comme entendu par téléphone a l'instant, j'ai essayé cette manip, mais sans succès, peut être aurez vous plus de chance,
http://notasin.blogspot.com/2011/11/how ... erial.html

Je fait part a mon collègue de votre souci, il avait déjà fait face a ce problème, il sera de retour demain.
Image - Distributeur officiel Arduino - Conception de shields
Avatar de l’utilisateur
Lionel
 
Messages: 734
Inscription: Mar 21 Déc 2010 09:52
Localisation: Toulouse

Re: Problème d'upload avec Arduino mini V04

Message non lude thriller91 » Mar 14 Fév 2012 00:09

Merci pour votre aide, mais cette solution ne fonctionne pas. Nous attendons avec impatience l'expérience de votre collègue :roll: .
thriller91
 
Messages: 3
Inscription: Lun 13 Fév 2012 12:16

Re: Problème d'upload avec Arduino mini V04

Message non lude thriller91 » Lun 20 Fév 2012 17:02

Merci pour l'échange d'adaptateur, vous avons réussit à uploader le programme Blink à l'aide du nouveau convertisseur USB vers Série. On a toutefois dû overrider l'écriture grâce à l'option -F d'arvdude parce qu'il y avait toujours un problème de signature.
Bref, ça marche, et on est bien content :mrgreen:
thriller91
 
Messages: 3
Inscription: Lun 13 Fév 2012 12:16

Re: (Contourné) Problème d'upload avec Arduino mini V04

Message non lude Lionel » Lun 20 Fév 2012 17:11

Bonjour,

content que ça marche,

mais je vous déconseille TRES FORTEMENT d'utiliser l'option -F d'avrdude sous peine de bricker votre atmega

il est préférable de trouver ou se situe votre souci plutot que de forcer l'envoi de code sans vérification de signature

quelle carte déclarez vous dans l'IDE arduino sous l'onglet Tools\board ?
Image - Distributeur officiel Arduino - Conception de shields
Avatar de l’utilisateur
Lionel
 
Messages: 734
Inscription: Mar 21 Déc 2010 09:52
Localisation: Toulouse

Re: (Contourné) Problème d'upload avec Arduino mini V04

Message non lude bNj » Jeu 23 Fév 2012 19:35

Bonjour,

j'ai le même problème, je n'arrive pas à programmer ce arduino mini :(
J'ai appliqué le fix indiqué sur le forum, rien n'y fait, je ne sais plus quoi faire ...

Benjamin
bNj
 
Messages: 4
Inscription: Mer 22 Fév 2012 12:09

Re: (Contourné) Problème d'upload avec Arduino mini V04

Message non lude Stéphane » Lun 27 Fév 2012 11:50

Bonjour,

Pouvez-vous donner plus de détail sur votre configurtation ?
Quelle version de l'IDE ? Quel système ? Quelle carte Arduino mini ? Quel convertisseur USB-UART ?

En vous remerciant,

S.
Avatar de l’utilisateur
Stéphane
 
Messages: 179
Inscription: Lun 2 Mai 2011 09:40

Re: (Contourné) Problème d'upload avec Arduino mini V04

Message non lude bNj » Mar 28 Fév 2012 23:22

Bonjour,

j'utilise la version 1.0 de l'IDE sur Windows x64.
J'ai acheté la carte Arduino Mini Light 04 et le convertisseur USB-UART sur snootlab.
Pouvez vous m'indiquer la manipulation pour uploader un programme ? Peut être que je m'y prends mal ...

Merci,

Benjamin
bNj
 
Messages: 4
Inscription: Mer 22 Fév 2012 12:09

Re: (Contourné) Problème d'upload avec Arduino mini V04

Message non lude Stéphane » Mer 29 Fév 2012 10:06

Bonjour,

pouvez-vous préciser quel est l'adaptateur USB-UART que vous avez exactement, car on a plusieurs références en boutique :)
Avatar de l’utilisateur
Stéphane
 
Messages: 179
Inscription: Lun 2 Mai 2011 09:40

Re: (Contourné) Problème d'upload avec Arduino mini V04

Message non lude bNj » Ven 2 Mar 2012 19:22

bNj
 
Messages: 4
Inscription: Mer 22 Fév 2012 12:09

Re: (Contourné) Problème d'upload avec Arduino mini V04

Message non lude bNj » Mar 13 Mar 2012 08:40

Stéphane a écrit:Bonjour,

pouvez-vous préciser quel est l'adaptateur USB-UART que vous avez exactement, car on a plusieurs références en boutique :)


Est ce que la photo vous a permis d'identifier la version de l'adaptateur ?
bNj
 
Messages: 4
Inscription: Mer 22 Fév 2012 12:09

Re: (Contourné) Problème d'upload avec Arduino mini V04

Message non lude Stéphane » Mar 13 Mar 2012 16:53

Bonjour,

Pouvez-vous me décrire la procédure suivie pour programmer l'Arduino mini ?
Avez-vous suivi ce tutoriel : tuto ?

Quelles sont les erreurs retournées par le logiciel Arduino lorsque vous tentez de programmer votre Arduino ?

Bonne journée :)
Avatar de l’utilisateur
Stéphane
 
Messages: 179
Inscription: Lun 2 Mai 2011 09:40

Re: (Contourné) Problème d'upload avec Arduino mini V04

Message non lude amys » Jeu 29 Mar 2012 00:06

j'ai trouvé la solution!
le mini 328 n'est pas pris en charge sous arduino 1.0, il faut donc utiliser une version précédente (la IDE 22 fonctionne trés bien)
il faut alors aller dans "{repertoire}\arduino\hardware\boards.txt et y coller (sans modifier les retour à la ligne):
"
##############################################################
mini328.name=Arduino Mini w/ ATmega328
mini328.upload.protocol=stk500
mini328.upload.maximum_size=28672
mini328.upload.speed=115200
mini328.bootloader.low_fuses=0xff
mini328.bootloader.high_fuses=0xd8
mini328.bootloader.extended_fuses=0x05
mini328.bootloader.path=optiboot
mini328.bootloader.file=optiboot_atmega328-Mini.hex
mini328.bootloader.unlock_bits=0x3F
mini328.bootloader.lock_bits=0x0F
mini328.build.mcu=atmega328p
mini328.build.f_cpu=16000000L
mini328.build.core=arduino
mini328.build.variant=eightanaloginputs
"

et hop, on selection la mini w328 dans boards et c'est partie pour un tour :)
amys
 
Messages: 1
Inscription: Jeu 29 Mar 2012 00:02

Re: (Contourné) Problème d'upload avec Arduino mini V04

Message non lude philippemartorell » Dim 13 Mai 2012 17:59

Mouip...

Ben non, la mini 04 328 est censée être prise en charge par la version 1.0 de l'IDE. Mais je confirme que cela ne marche pas sous plusieurs machines, que ce soit sous XP, Mageia ou Ubuntu 11.04 spécialement installée pour l'occasion. Alors que je crois l'avoir vu marcher sur une machine qui m'appartiens pas !!!!!! ( Je ne saurais dire quelle distribution, mais nécessairement une version 1.0 de l'IDE)

La version 22 ne marche pas plus, que ce soit en version originale ou modifiée suivant tes conseils.

Bon, je maîtrise pas trop tout ça, mais je commence à soupçonner un truc plus vicieux, genre interface java ou pire...
philippemartorell
 
Messages: 42
Inscription: Ven 9 Déc 2011 11:37

Re: (Contourné) Problème d'upload avec Arduino mini V04

Message non lude Lionel » Mar 15 Mai 2012 11:20

Bonjour
Quel adaptateur utilises tu Philippe ?
Image - Distributeur officiel Arduino - Conception de shields
Avatar de l’utilisateur
Lionel
 
Messages: 734
Inscription: Mar 21 Déc 2010 09:52
Localisation: Toulouse

Re: (Contourné) Problème d'upload avec Arduino mini V04

Message non lude subreptice » Mar 15 Mai 2012 13:13

Bonjour Lionel, Philippe.

Je pense avoir reconnu celui-là :
http://shop.snootlab.com/arduino/73-adaptateur-usb-arduino-mini.html

Contrairement à ce que nous avons fait Samedi, je pense qu'il faut tester la mini et son adaptateur en dehors du shield maison, sauf ton respect hein Philippe :mrgreen: , il avait l'air de très bonne facture ton shield, c'est juste une question de debug en partant de la racine.
subreptice
 
Messages: 58
Inscription: Mar 19 Juil 2011 18:04

Re: (Contourné) Problème d'upload avec Arduino mini V04

Message non lude Lionel » Mar 15 Mai 2012 13:21

Re-,
Les branchements (de samedi ?!) ont ils respectés les consignes du site officiel arduino ?
http://arduino.cc/en/Guide/ArduinoMini#connecting

je pense notamment à la pin reset...
Reset. Whenever this pin is connected to ground, the Arduino Mini resets. You can wire it to a pushbutton, or connect it to +5V to prevent the Arduino Mini from resetting (except when it loses power). If you leave the reset pin unconnected, the Arduino Mini will reset randomly.


Ensuite, te serait il possible Philippe, de poster ici l'extrait du fichier board.txt concernant la carte mini ?

je vais aussi séparer les fils de discussions, le problème précédent concernait une carte USB2Serial, pas une carte avec puce FTDI...
Image - Distributeur officiel Arduino - Conception de shields
Avatar de l’utilisateur
Lionel
 
Messages: 734
Inscription: Mar 21 Déc 2010 09:52
Localisation: Toulouse

Re: (Contourné) Problème d'upload avec Arduino mini V04

Message non lude subreptice » Mar 15 Mai 2012 13:37

Oui Samedi dernier à PSMP nous avons essayé ce module de Philippe.

Les branchements (de samedi ?!) ont ils respectés les consignes du site officiel arduino ?
http://arduino.cc/en/Guide/ArduinoMini#connecting


:mrgreen: encore bien vu Lionel !
Je ne sait pas quoi dire vu que le module, c'est la mini + son adaptateur + un module radio je crois, le tout pluggé sur un shield maison très joli, mais dont je n'ai pas détaillé les connexions ...
Au mieux, nous nous sommes heurtés au message "avr-dude stk500 ~not responding"

Philippe je pense que ça vaut la peine de réessayer avec la mini et l'adaptateur seuls, en prenant soin de relier la broche de reset au 5v comme l'indique Lionel.
subreptice
 
Messages: 58
Inscription: Mar 19 Juil 2011 18:04

Re: (Contourné) Problème d'upload avec Arduino mini V04

Message non lude philippemartorell » Mar 15 Mai 2012 13:47

Merci de votre intérêt.

Donc oui, subreptice, c'est bien cet adaptateur, le votre.
Oui, j'ai eu moi même des doutes sur le shild maison, et j'ai déconnecté la HF.
Le reset étais sur 5V direct, j'ai essayé déconnecté. (je lis très mal l'anglais)
J'ai eu un doute sur le croisement des TX et RX, mais à priori j'ai vu direct. J'ai essayé l'inverse (croisé), mais là j'ai une autre erreur, la même que sans la Arduino. Donc je conclus qu'il faut bien direct.
Après quelques tâtonnements sur le fichier board.txt, je l'ai rechargé pour repartir de la base originale. Lionel, tu disais que c'était utile que pour Seven il me semble.

Voilà...

En attendant, je vais monter le tout sur une bread board
philippemartorell
 
Messages: 42
Inscription: Ven 9 Déc 2011 11:37

Re: (Contourné) Problème d'upload avec Arduino mini V04

Message non lude Lionel » Mar 15 Mai 2012 14:33

Hmmm, je n'ai pas tout à fait compris
du coup Philippe, ça marche ou non ?
Image - Distributeur officiel Arduino - Conception de shields
Avatar de l’utilisateur
Lionel
 
Messages: 734
Inscription: Mar 21 Déc 2010 09:52
Localisation: Toulouse

Suivante

Retourner vers Arduino

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités

cron