Page 1 sur 2

probleme windows 7 + arduino

Message non luPosté: Mer 11 Mai 2011 18:49
de patrick
Bonjours à tous
je viens de recevoir ma commande de snootlab passer lundi super
j'ai délicatement ouver la tres jolie boite de mon arduino
j'ai connecter et le transfo et USB
j'ai demarer le logiciel arduino > outil > carte > uno
outil > ports série et grisée donc ne fonctionne pas !
Dans le gestionnaire de perif de windows 7 à autre perif > arduino uno il y avertissement
qu'il n'a pas trouver le pilote
quel et la procédure
merci par avance de votre aide
suis-je claire dans mon explication !

Re: probleme windows 7 + arduino

Message non luPosté: Mer 11 Mai 2011 19:46
de Lionel
Installation des pilotes pour la carte Arduino Uno sous Windows7, Vista ou XP:

Brancher la carte et attendre que Windows commence son processus d'installation du pilote.
Après quelques instants, le processus échouera, malgré tous ses efforts

Cliquer sur le menu Démarrer, puis ouvrez le Panneau de configuration.
Une fois dans le Panneau de configuration, aller à Système et sécurité.

Ensuite, cliquer sur Système. Une fois la fenêtre du système ouverte, ouvrir le Gestionnaire de périphériques.

Regarder sous Ports (COM et LPT). Il devrait y avoir un port ouvert nommé "Arduino UNO (COMxx)"

Faire un clic droit sur ​​le "Arduino UNO (COMxx)" port et choisir l'option "Mettre à jour le pilote".

Ensuite, cliquer sur bouton «Parcourir ...".

Enfin, rechercher et sélectionner le fichier du pilote de la Uno, nommé "ArduinoUNO.inf", situé dans le dossier "Drivers" du logiciel Arduino (pas le sous-répertoire "FTDI USB Drivers").

Windows devrait finaliser l'installation du pilote.

(trad rapide de : http://www.arduino.cc/en/Guide/Windows)

Re: probleme windows 7 + arduino

Message non luPosté: Jeu 12 Mai 2011 17:51
de patrick
Bonsoir a tous
j'ai bien tester et retester :
gestion perif >autre perif>arduino uno>mettre le pilote a jour>recherche sur ordi>parcourir>
arduino>driver!!!!!!! pas de arduinoUNO.inf
que du .svn ou bien FTDI USB driver
que me conseiller vous ; j'ai bien verifier
par avance merci

Re: probleme windows 7 + arduino

Message non luPosté: Jeu 12 Mai 2011 18:05
de Stéphane
Bonsoir,

Quand tu as récupéré l'environnement Arduino, tu l'as mis où sur ton ordinateur ?
Dans ce dossier (arduino-022 chez moi), tu as un sous-dossier drivers, contenant :
- "Arduino MEGA 2560.inf"
- "Arduino UNO.inf"
- un dossier nommé "FTDI USB Drivers"

Que contient ton dossier Arduino/drivers ?

----
Stéphane

Re: probleme windows 7 + arduino

Message non luPosté: Jeu 12 Mai 2011 18:26
de patrick
dans mon dossier "arduino-0018-fr" que j'ai deziper
j'ai un sou dossier "driver"
il y a ".svn","FTDI USB driver"
voila ce que j'ai!

Re: probleme windows 7 + arduino

Message non luPosté: Jeu 12 Mai 2011 18:35
de Stéphane
Ok, parfait.

Rends toi à cette adresse : http://arduino.googlecode.com/files/arduino-0022.zip
Et prends cette dernière version de l’environnement Arduino.

En effet, le support des Arduino UNO et des Arduino Mega ne sont pris en charge qu'à partir de la version 20 de l'environnement.

Avec la version 22 (la dernière), ce sera parfaitement à jour, et tu pourras appliquer sans problème la démarche de Lionel !

Si cela ne marche toujours pas avec la version 22, je t'attends sur le forum ! :)

Bonne soirée

-----

Stéphane

Re: probleme windows 7 + arduino

Message non luPosté: Jeu 12 Mai 2011 19:07
de patrick
stephane merci
j'ai pu charger le pilote de la carte :
arduino-0022>driver
et windows a percuter!!!!!!!!!
je vais essayer ca toute a l'heure
merci pour tout
bonne soirée

Re: probleme windows 7 + arduino = plus de problemes

Message non luPosté: Jeu 12 Mai 2011 20:34
de patrick
rebonsoir
j'ai reusi a fair clignoter une led pour essai ça marche
merci pour le pilote je n'aurais pas pu trouver
bonne soirée

Re: probleme windows 7 + arduino

Message non luPosté: Jeu 12 Mai 2011 21:08
de Stéphane
Parfait, n'hésites pas si tu as d'autres questions, c'est le lieu pour les poser.

Bonne soirée.

-----
Stéphane

Re: probleme windows 7 + arduino

Message non luPosté: Jeu 8 Sep 2011 20:58
de nico
Bonjour,

je viens d'acquérir cette carte http://shop.snootlab.com/arduino/115-ar ... -usb2.html.

Malheureusement, quand j'essaie d'installer le driver de la version arduino-0022 sous Windows 7 64bits, Windows ne trouve pas le driver (je fais pourtant pointer la mise à jour de pilote vers arduino-0022/drivers) :(

J'ai l'entrée suivante dans le fichier Windows/inf/setupapi.dev.log (fichier de log des installations de périphériques USB) :

Code: Tout sélectionner
>>>  [Device Install (DiShowUpdateDevice) - USB\VID_2341&PID_003B\6493633313735151F122]
>>>  Section start 2011/09/08 21:46:00.446
      cmd: "C:\Windows\system32\mmc.exe" C:\Windows\system32\devmgmt.msc
     dvi: {DIF_UPDATEDRIVER_UI} 21:46:00.451
     dvi:      No class installer for 'Arduino USB-Serial'
     dvi:      Default installer: Enter 21:46:00.460
     dvi:      Default installer: Exit
     dvi: {DIF_UPDATEDRIVER_UI - exit(0xe000020e)} 21:46:00.469
     ndv: {Update Driver Software Wizard for USB\VID_2341&PID_003B\6493633313735151F122}
     ndv: {Update Driver Software Wizard exit(00000000)}
<<<  Section end 2011/09/08 21:46:11.999
<<<  [Exit status: SUCCESS]


J'ai également testé sur un PC sous Windows XP, l'OS ne trouve pas non plus le driver...

Une idée ?

Re: probleme windows 7 + arduino

Message non luPosté: Jeu 8 Sep 2011 21:56
de nico
Bon, j'ai trouvé une solution.

C'était un problème de device id pour l'USB :
Windows cherchait le device suivant :
ndv: {Update Driver Software Wizard for USB\VID_2341&PID_003B\6493633313735151F122}


Alors que le driver (fichier drivers/Arduino UNO.inf) contient le VID et le PID suivant :
[DeviceList]
%DESCRIPTION%=DriverInstall, USB\VID_2341&PID_0001

[DeviceList.NTamd64]
%DESCRIPTION%=DriverInstall, USB\VID_2341&PID_0001


J'ai donc modifié le fichier drivers/Arduino UNO.inf pour mettre :
[DeviceList]
%DESCRIPTION%=DriverInstall, USB\VID_2341&PID_003B

[DeviceList.NTamd64]
%DESCRIPTION%=DriverInstall, USB\VID_2341&PID_003B


Et ça a fonctionné, j'ai réussi à faire le blink de LED ;-)

Bref, je me demande si je n'ai pas une toute dernière version de la carte USB2SERIAL et que le driver n'est pas encore dispo chez Arduino....

Re: probleme windows 7 + arduino

Message non luPosté: Jeu 8 Sep 2011 23:04
de Lionel
Bonjour,

Merci pour l'info sur la manip,

avez vous essayé le driver pour windows (.inf) fourni sur la page de la carte usbserial ?

Re: probleme windows 7 + arduino

Message non luPosté: Ven 9 Sep 2011 07:22
de nico
Ah non, je ne l'avais pas vu celui là...
Et apparemment, il devrait fonctionner vue le contenu du fichier.

J'essaierai ça et vous tiendrai au courant.

Re: probleme windows 7 + arduino

Message non luPosté: Ven 9 Sep 2011 09:05
de Stéphane
Bonjour,

En effet, chaque carte nécessitant un driver possède son propre driver. Arduino UNO.inf est le driver de la carte Arduino UNO, si tu veux qu'il continue à fonctionner avec sa carte, il ne faut pas le modifier.
Prendre le driver sur le site Arduino comme l'a pointé Lionel est la meilleure chose à faire :)

Bonne journée,

-----
Stéphane

Re: probleme windows 7 + arduino

Message non luPosté: Dim 11 Sep 2011 15:48
de nico
J'ai essayé avec le driver indiqué par Lionel, et ça fonctionne parfaitement !

Merci :)

Re: probleme windows 7 + arduino

Message non luPosté: Jeu 6 Oct 2011 20:52
de klmnl
de klmnl nouveau et pas futé. win seven 64 arduino version 022 mega 2560.
la carte connectée à un XP home a fonctionné sans Pb.
A mon seven 64 voici le résultat.
que faut il faire ?
je n'arrive pas à trouver la ligne port com et lpt.

Re: probleme windows 7 + arduino

Message non luPosté: Jeu 6 Oct 2011 21:04
de Lionel
Bonsoir,

Laissez la carte mega connectée,

bouton de droite dessus,
mise a jour du driver (ou un message dans ce style)
aller chercher le driver dans le dossier arduino022/drivers (pas plus loin dans le sous répertoire FTDI USB)

Ca devrait fonctionner !

Re: probleme windows 7 + arduino

Message non luPosté: Jeu 6 Oct 2011 21:12
de klmnl
de klmnl
En plus de pas être futé, je suis vraiment le roi dec.. a pas lire jusqu'au bout.
merci Lionel.

Re: probleme windows 7 + arduino

Message non luPosté: Mar 10 Jan 2012 07:12
de billscott59
Bonjour,
j'ai reçu avec joie mon joli arduino uno et son starter kit hier soir,
et la c'est le drame ! :)
win 7 refuse de le reconnaitre...
et meme en surfant impossible de le faire démarrer...
voila pour finir la solution que j'ai trouvé, désolé si ça fait doublon.

dans le gestionnaire de périfs,il n'y avait pas de port/ltp

donc:panneau de configuration
systeme
gestionnaire de péripherique
la, sous appareil mobile vous avez "peripherique inconnue": click doit :mettre a jour le pilote
recherché un pilote sur mon ordinateur
et la important clicker sur "choisir parmis une liste de pilote de peripherique sur mon ordinateur"
puis:"disque fournis"

et la cherché "driver" dans le logiciel arduino puis "uno" si c'est une uno....

et ca marche !

vous avez maintenant "port com "dans le gestionnaire de peripherique" avec le numero du port com !

enjoy !

laurent

Re: probleme windows 7 + arduino

Message non luPosté: Sam 18 Fév 2012 06:53
de alain_g
billscott59 a écrit:Bonjour,
j'ai reçu avec joie mon joli arduino uno et son starter kit hier soir,
et la c'est le drame ! :)
win 7 refuse de le reconnaitre...
et meme en surfant impossible de le faire démarrer...
voila pour finir la solution que j'ai trouvé, désolé si ça fait doublon.
...
laurent


Bonjour à tous et merci Laurent. J'avais exactement le même problème et ton astuce a tout résolu. J'avais pourtant installé une première fois ces driver sur un autre PC sous seven et cela avait fonctionné du 1er coup mais là il ne voulait rien savoir...

Merci encore

Alain