Émetteur - Récepteur 434MHz !

Parlez nous de vos projets et de vos idées, imaginez des applications

Émetteur - Récepteur 434MHz !

Message non lude SaW3r » Sam 24 Déc 2011 12:37

Bonjour, tout d'abord je précise que j'ai placé ce sujet dans la rubrique "Projet" car il n'y avait pas de section pour ces composants (comme la section pour la liaison IR par exemple). Enfin bref, je viens vers vous car j'ai un petit soucis au niveau du récepteur et je voudrais savoir si cela est normal. Je précise que je dispose bien des composants à vendre sur le site soit :

Émetteur : http://shop.snootlab.com/composants/147-emetteur-rf-434-mhz.html
Récepteur : http://shop.snootlab.com/composants/145-recepteur-rf-434-mhz.html

Alors voila mon système consiste en faite tout simplement à allumer plusieurs LEDS mais à distance, c'est à dire que lorsque que ma LED1 va s'allumer, l'émetteur branché à celle-ci va se mettre au +5V (sortie arduino active) sur la broche DATA et le montage va donc transmettre. Vous aurez donc compris la suite, lorsque l'émetteur va recevoir un signal "fort" il va faire en sorte d'allumer la LED2.

Jusqu'ici tout se passe bien mais le problème vient du fait que lorsque je n'émet pas avec mon émetteur, le récepteur reçois un signal "fort" quand même ! Il n'y aurais eu qu'un petit signal parasite je n'aurais rien dit mais la il est aussi puissant que celui de mon émetteur disposé à quelques centimètres seulement !

Lorsque j'observe une des deux sorties DATA du récepteur à l'aide d'un "analogRead" sur le "serial monitor" j'obtient soit la valeur "0" (ce qui est tout à fait normal vu que je n'envoi rien), soit une valeur entre "1015" et "1019" et la je ne comprends pas.. Serais-ce mon récepteur qui "déconne" ou alors un émetteur voisin que je recevrais de "temps en temps" ? C'est assez agaçant car cela perturbe complètement mon système et il n'est donc plus fiable du tout..

Le problème vient peut-être de mon antenne ? J'ai dénudé un fil de 17,3cm de long et j'ai essayé avec un de 17cm aussi mais aucun changement.

Voici mon programme (très simple) :

Code: Tout sélectionner
int outputValue1 = 0;
int outputValue2 = 0;

void setup() {
  Serial.begin(115200);
  pinMode(13, OUTPUT);
}

void loop() {
  outputValue1 = analogRead(A0);
  delay(10);
  outputValue2 = analogRead(A0);
  if(outputValue1 != outputValue2){
  Serial.println(outputValue1);
  Serial.println(outputValue2);
  if((outputValue1 > 1000) && (outputValue2 > 1000)){digitalWrite(13, HIGH);}else{digitalWrite(13, LOW);}
}
}



Merci à vous et j'ai un projet plus intéressant à mettre en oeuvre avec ce système si vous m'aidez à parvenir à régler ce problème.
SaW3r
 
Messages: 58
Inscription: Sam 24 Déc 2011 12:13
Localisation: Paris

Re: Émetteur - Récepteur 434MHz !

Message non lude SaW3r » Mer 28 Déc 2011 20:16

Personne ? Je m'adresse surtout aux administrateurs du Forum qui disposent du matériel, si vous avez un peu de temps pourriez-vous faire des essais et me tenir au courant ? Je vous en serais très reconnaissant, merci !

PS: J'ai une autre question car ceci n'est indiqué nul part, pourquoi il y a 2 sorties DATA sur le récepteur ? Il y en a une qui, dans mon cas, reste tout le temps à 0 et donc je ne vois pas son intérêt même si je me doute qu'elle doit servir à quelque chose, pourriez-vous m'éclairez ?
SaW3r
 
Messages: 58
Inscription: Sam 24 Déc 2011 12:13
Localisation: Paris

Re: Émetteur - Récepteur 434MHz !

Message non lude Lionel » Jeu 29 Déc 2011 18:37

Bonjour,

le support est en veille ces jours ci pour cause de "repos", nous n'avons pas pris de couple émetteur/récepteur pour tester, pensez à nous relancer lundi ou mardi.

Sinon, l'antenne de 17cm ou 17,3 convient bien

Pourrez vous poster vos schémas et/ou photo de câblage ainsi que le code que vous utilisez pour réaliser votre liaison sans fil.
Image - Distributeur officiel Arduino - Conception de shields
Avatar de l’utilisateur
Lionel
 
Messages: 734
Inscription: Mar 21 Déc 2010 09:52
Localisation: Toulouse

Re: Émetteur - Récepteur 434MHz !

Message non lude SaW3r » Ven 30 Déc 2011 17:49

Bonsoir, pas de soucis je le comprends très bien qu'en ce moment tout le monde se repose :)

Parfait pour l'antenne alors je la garde.

EDIT: J'ai finalement réussi, j'ai suivi ce tutoriel : http://letsmakerobots.com/node/12336

La seule différence est que je l'ai fait avec 2 Duemilanove et donc la broche RX n'est plus la 23 mais la 11.

Je vous propose de créer une partie dédiée à ce couple d'émetteur - récepteur comme la partie pour le shield DEULIGNE par exemple et je pourrais vous rédiger un tutoriel simple et court ^^
SaW3r
 
Messages: 58
Inscription: Sam 24 Déc 2011 12:13
Localisation: Paris

Re: Émetteur - Récepteur 434MHz !

Message non lude SaW3r » Mar 3 Jan 2012 14:03

Vous n'êtes pas intéressés ?
SaW3r
 
Messages: 58
Inscription: Sam 24 Déc 2011 12:13
Localisation: Paris

Re: Émetteur - Récepteur 434MHz !

Message non lude Lionel » Mar 3 Jan 2012 14:25

Absolument que nous sommes interessés, mais je n'avais pas vu votre proposition,
nous ne sommes pas avertis par mail lors de l'édition d'un message existant
Je vais créer la partie du forum d'ici qques minutes, merci.
Image - Distributeur officiel Arduino - Conception de shields
Avatar de l’utilisateur
Lionel
 
Messages: 734
Inscription: Mar 21 Déc 2010 09:52
Localisation: Toulouse

Re: Émetteur - Récepteur 434MHz !

Message non lude SaW3r » Mar 3 Jan 2012 14:48

Très bien je commencerais à rédiger ça ce soir alors si le forum est créé d'ici la :)
SaW3r
 
Messages: 58
Inscription: Sam 24 Déc 2011 12:13
Localisation: Paris

Re: Émetteur - Récepteur 434MHz !

Message non lude SaW3r » Mer 4 Jan 2012 22:57

Bonsoir, je reviens vers vous car j'ai un problème assez.. inattendu ! En effet je me suis rendu compte que l'émetteur venait à brouiller mon portail automatique lorsque celui-ci était allumé et j'ai vite compris pourquoi. Pratiquement tous les portails électriques fonctionnent à la fréquence 433.92MHz donc très proche de 434MHz et ça je n'y avais complètement pas pensé. Cela me pose un énorme problème vu que je ne peux tout simplement plus utiliser mon portail pendant que mon émetteur est allumé et je comptais bien utiliser les deux en même temps !

Je me suis alors dit qu'il y avais surement une solution à ce problème, j'ai alors cherché à limité la portée au minimum du minimum possible, c'est à dire en l'alimentant en 3VDC et en lui paramétrant une vitesse de 9000 bps (la vitesse de fonctionnement qui confère la portée minimal d'après la documentation de la librairie VirtualWire) mais rien n'y fait mon portail est toujours brouillé !

Sauriez-vous comment je pourrais faire ? Je serais vraiment déçu que cela ne fonctionne pas ensemble.. Ou sinon quelle autre système serait-il envisageable ? L'émetteur et le récepteur sont distants d'environ 2 mètres mais il y a un mur entre les deux donc la solution de l'infrarouge est à exclure malheureusement. Merci d'avance pour votre aide !
SaW3r
 
Messages: 58
Inscription: Sam 24 Déc 2011 12:13
Localisation: Paris

Re: Émetteur - Récepteur 434MHz !

Message non lude Lionel » Jeu 5 Jan 2012 12:50

Bonjour,

Ah oui, effectivement, il y a du monde sur la ligne 433.9... avez vous essayé de changer la taille de l'antenne ?
A 17 cm elle est "adaptée" en quart d'onde, et la portée du couple émetteur/récepteur est plus grande, si vous la rendez "inadaptée" (plus courte par exemple) vous devriez réduire drastiquement sa portée.
C'est un peu de l'anti-électronique, mais l’électronique, c'est parfois aussi de la cuisine :)
On pourrait aussi changer de bande de fréquence, mais en France, très peu sont disponibles, expliquant en partie notre notre offre limitée...

http://www.anfr.fr/fr/faq/questions-rep ... rbf17.html
Notre entreprise teste des modules de faible puissance (environ 25 mW en émission) avec une portée d'environ 300 m qui fonctionnent avec des piles de 3 V. Ces appareils servent à faire des mesures. Les fréquences utilisables sont les suivantes : 315,8 MHz, 433,0 MHz, 434,8 MHz, 914,1 MHz et 915,9 MHz. Quelles sont celles autorisées en France ?

Les fréquences utilisées par ces modules qui sont autorisées sont :
433,0 MHz (10 mW de puissance) ;
868 MHz (10 mW de puissance).

Les fréquences interdites sont :
315,8 MHz ;
434,8 MHz (la limite supérieure autorisée est 434,79 MHz) ;
914,1 MHz (bande GSM) ;
915,9 MHz (bande Défense).
Image - Distributeur officiel Arduino - Conception de shields
Avatar de l’utilisateur
Lionel
 
Messages: 734
Inscription: Mar 21 Déc 2010 09:52
Localisation: Toulouse

Re: Émetteur - Récepteur 434MHz !

Message non lude SaW3r » Sam 7 Jan 2012 16:48

Bonjour et merci pour cette réponse très précise. Effectivement j'ai bien essayé de changer la taille de l'antenne et même de l'enlever complètement carrément mais rien n'y fait mon portail capte toujours.. Surement son antenne qui est trop puissante ! Mais j'ai trouvé une autre "technique" et je peux maintenant me servir de mon portail et émettre en même temps :D

Je vous partagerais tout cela lorsque je laisserais un petit tutoriel à propos de ce couple d'émetteur - récepteur dans la partie que vous avez crée à cet effet. Voila tout Bonne journée :)
SaW3r
 
Messages: 58
Inscription: Sam 24 Déc 2011 12:13
Localisation: Paris


Retourner vers Vos projets, vos idées

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités