Starter kit chapitre 0

Le forum du Snootlab Starter Kit

Starter kit chapitre 0

Message non lude joucks » Sam 31 Déc 2011 19:26

Bonsoir,

J'ai eu comme super cadeau de noel le starter kit avec arduino !!

Je vais donc commencer les exercices donnés dans ce forum. Par contre j'ai déjà une qsuestion sur le chapitre 0. On parle de l'AOP qui est là pour réguler les impédances, mais que se passe-t-il si on n'en met pas ? J'essayerai bien mais je ne voudrais pas crâmer mon joli cadeau au premier essai.

Merci et bon réveillon !
joucks
 
Messages: 3
Inscription: Sam 31 Déc 2011 18:56

Re: Starter kit chapitre 0

Message non lude Stéphane » Lun 2 Jan 2012 10:09

Bonjour,

l'AOP est présent à but didactique. Dans la situation du chapitre 0, l'AOP n'est pas indispensable, seulement, c'est un bon exemple pour apprendre à avoir le "réflexe" d'adapter ses impédances. Il est des cas, notamment pour des chaînes d'acquisition de mesure, où l'adaptation d'impédance est primordiale. Cet exemple met en lumière ce concept, de manière simple :)

Mais ne vous en faites pas, vous pouvez essayer sans, vous ne casserez pas votre cadeau ! :)

Bonne journée
Avatar de l’utilisateur
Stéphane
 
Messages: 179
Inscription: Lun 2 Mai 2011 09:40

Re: Starter kit chapitre 0

Message non lude joucks » Dim 22 Jan 2012 16:43

Bonjour,

Je suis au chapitre 2 avec capteur de vibration et buzzer. Tout fonctionne bien, je me suis amusé à ajouter une led qui s'allume en même temps que le buzzer.

Par contre j'ai voulu essayé de mettre AOP pour ajuster les impédances et là hic...
Je vous décris le branchement que j'ai fait :
Borne 1 AOP : sur analogique arduino 2
Borne 2 AOP : sur borne 1 AOP
Borne 3 AOP : sur résistance + capteur en parallèle
Borne 4 AOP : sur GND
Borne 8 : sur rien !

Lorque je mets tout en route le buzzer sonne sans arrêt mais en changeant de tonalité tout seul.

Pouvez-vous me décrire comment brancher l'AOP pour voir ce qu'apporte l'ajustement d'impédace car je ne comprends toujours pas l'utilité :) !
joucks
 
Messages: 3
Inscription: Sam 31 Déc 2011 18:56

Re: Starter kit chapitre 0

Message non lude Stéphane » Lun 6 Fév 2012 18:44

Bonjour,

Votre AOP ne fonctionnera pas sans alimentation. Comme tout composant actif (moteur, CI, etc etc) il nécessite d'être alimenté.
Je vous conseille de lire la documentation du composant, au moins les premières pages qui vous permettront de connaître le brochage de ce composant.

Bonne journée ! :)
Avatar de l’utilisateur
Stéphane
 
Messages: 179
Inscription: Lun 2 Mai 2011 09:40

Re: Starter kit chapitre 0

Message non lude Bemolu » Mer 8 Fév 2012 21:40

Je récupère ce sujet pour faire 2 commentaires sur le sujet maintenant verrouillé "Starter kit chapitre 0":
- en réponse au dernier message:
Message de franck31 » Lun 8 Aoû 2011 22:47
Bon, j'ai fait le montage mais y'a quelque chose qui m'étonne:
- lorsque je joue avec le curseur du potentiomètre, je passe très vite du mini (14) au maxi (environ 730). J'ai du mal à obtenir des valeurs intermédiaire.
Me serais-je trompé dans le montage ? a+, Franck

=> je pense que tu as installé un résistance de 1 kOhm (marron noir rouge) au lieu de 10 kOhm (marron noir orange). L'effet est typiquement ce que tu décris. Les valeurs extrêmes sont atteintes sur 1/10 de la course au lieu de la plage entière.

- à propos du montage lui-même
Il est inutile de court-circtuiter les deux bornes S et E, la borne E peut être laissée 'en l'air' sans danger. Cela simplifie quand même la réalisation: inutile d'aller chercher la dernière patte du potentiomètre.
Bemolu
 
Messages: 63
Inscription: Mer 8 Fév 2012 21:19

Re: Starter kit chapitre 0

Message non lude joe » Mer 16 Mai 2012 16:52

Bonjour, pour ne pas lancer un autre post sur le chapitre 0, je poste à la suite.

Ce chapitre 0, est mon premier montage, il s'est bien dérouler, mais je me demande si mon resultat est celui recherché, la variation est bien lineaire mais à fond de curseur je n'ai pas 1023 mais 534, est-ce normal docteur?
joe
 
Messages: 3
Inscription: Mer 16 Mai 2012 16:31

Re: Starter kit chapitre 0

Message non lude joe » Mer 16 Mai 2012 18:31

j'ai trouvé en partie ma réponse, j'avais oublier cette histoire de pont diviseur... :oops:

calcul du pont diviseur

si on a R2=R1 la tension est diviser par 2, donc à fond de potentiomètre ont est egale a la resistance donc 5v diviser par 2, donc je devrais avoir environ 1024 / 2 soit 512 (2,5v) et non 534 (2,6v) !

Pourquoi cette difference ?
joe
 
Messages: 3
Inscription: Mer 16 Mai 2012 16:31

Re: Starter kit chapitre 0

Message non lude Bemolu » Lun 21 Mai 2012 20:48

joe a écrit:[...]si on a R2=R1 la tension est diviser par 2, donc à fond de potentiomètre ont est egale a la resistance donc 5v diviser par 2, donc je devrais avoir environ 1024 / 2 soit 512 (2,5v) et non 534 (2,6v) !
Pourquoi cette difference ?


Les tolérances sur les résistances sont souvent de 5%. On est encore dans la tolérance: 512 +/-5% = [486 - 537].
De plus, les valeurs peuvent changer avec les températures (ambiante / composant). Sans compter les résistance parasites qui peuvent apparaître dans un montage (qualité des contacts, longueurs des liaisons, ...).

Si tu veux 'améliorer' la performance de ta mesure, tu peux l'étalonner, puis utiliser l'instruction map dans l'Arduino. Tu peux aussi rajouter une résistance faible en amont pour compenser la 'faiblesse' de ta première résistance.

Dans le cas de l'exemple du starter kit chapitre 0, je pense qu'on peut largement s'accomoder de la tolérance des résistances.
Bemolu
 
Messages: 63
Inscription: Mer 8 Fév 2012 21:19

Re: Starter kit chapitre 0

Message non lude panpan » Dim 2 Sep 2012 14:24

Bonjour à tous,
c’est mon premier post.
merci pour ces petites leçons.
J’adore commencer par des cas pratiques.

J’ai trouvé dommage que le montage ne soit plus explicite. autant l’AOP est assez simple à monter, autant les branchements du potentiomètre sont assez flous sur le schéma, et pas facile à comprendre pour un débutant, qui a tendance à avoir peur de tout faire griller !! peut-être que des photos peuvent dédramatiser la situation !!

étant donné que j'y suis quand même arrivé !!
je vous montre une photo. ça aidera peut-être quelqu'un, on ne sait jamais.
Image

merci encore au rédacteur malgré cela.

en bonus j’ai augmenté le principe qui au lieu d’afficher le résultat via le retour port série,
fait un retour du niveau sur un circuit parallèle de 3 Leds Rouge/Orange/Vert.

et voilà une photo de ce bonus !!
Image
Image
Avatar de l’utilisateur
panpan
 
Messages: 14
Inscription: Dim 2 Sep 2012 14:01
Localisation: Paris 15

Re: Starter kit chapitre 0

Message non lude Stéphane » Lun 3 Sep 2012 14:06

Super !

Merci pour ces photos panpan, si cela peut aider effectivement des gens, c'est parfait ! :)
Avatar de l’utilisateur
Stéphane
 
Messages: 179
Inscription: Lun 2 Mai 2011 09:40

Re: Starter kit chapitre 0

Message non lude robby » Lun 29 Oct 2012 13:07

Bonjour.
Je ne sais pas où me présenter sur ce forum.
J'ai acheté un kit dans le but de comprendre plutot que de recopier bêtement des projets déjà écrits. Mon but est de créer un systéme d'automatisation pour aquarium d'eau de mer complet, avec gestion de la température, de l'évaporation et de l'éclairage par LED (simualation des cycles diurne, nocturne et lunaire) le tout contrlé par un écran tactile. Cela est déjà fait...
J'avoue avoir du mal à comprrendre effectivement comment brocher le potar, moi je l'ai mis direct sur les breadboard mais j'ai du me planter ça ne fonctionne apparemment pas. Donc merci pour les photos car c'est une vraie aide mais
1. elles ne sont pas conformes au plan proposé
2. les bredboards du kit sont plus petites...
robby
 
Messages: 3
Inscription: Lun 29 Oct 2012 12:56

Re: Starter kit chapitre 0

Message non lude Stéphane » Lun 29 Oct 2012 15:02

Bonjour,

Je ne comprends pas pourquoi vous trouvez qu'elles ne sont pas conformes au plan proposé puisque c'est le plan proposé.
Pour la suite, je vous assure, vous pouvez compter les trous, ce sont bien les mêmes breadboard que celles du starterkit :)

Quand aux branchements, que vous les mettiez sur des breadbaord ou des fils, cela ne change rien.
Avatar de l’utilisateur
Stéphane
 
Messages: 179
Inscription: Lun 2 Mai 2011 09:40

Re: Starter kit chapitre 0

Message non lude teriak » Mer 26 Déc 2012 15:21

Bonjour,

Sur les conseils d'un ami, j'ai acheté 2 starters kits , un pour moi et un pour ma soeur qui voulait elle aussi s'initier.
Tout le monde m'avait dit tu vas voir c'est easy!
Ok, cool. Je regarde le forum et je vois des tutos. Parfait.

Je teste. et là je ne comprends absolument rien!!!
Première réaction, je suis blasé de mon achat... A moins que l'on me guide un peu plus puisque, apparemment je suis un peu plus con que la moyenne vu que je n'arrive même pas à mettre en place le premier pallier.

Mes interrogations:
1/ comment se branche le potentiomètre????
2/ J'ai téléchargé le logiciel Arduino sur http://arduino.cc/fr/Main/TelechargerArduinoFrancais
Le logiciel démarre et je colle le code.
Jusqu'ici ça va . Mais après , je fais quoi?
3/ dois je installer des drivers pour ma carte arduino?
4/ Certains post parlent de valeurs. mais je les "voient" où et comment ces valeurs? Sur le logiciel?

Bref, je sais pas trop quoi faire :?
Please, help me!
teriak
 
Messages: 4
Inscription: Mer 26 Déc 2012 15:11

Re: Starter kit chapitre 0

Message non lude teriak » Mer 26 Déc 2012 16:17

Après moult recherche, je crois que déjà ma carte n'est pas bien installé!
je m'explique.
Dans le logiciel Arduino Alpha, outil > port série , j'ai seulement com1 et il est validé.
Cependant mon windows7 ne reconnait pas mon nouveau péréiphérique.
Du coup qd j'essaie de transférer le programme, j'ai ce message d'erreur:

"processing.app.SerialException: Serial port 'COM1' already in use. Try quiting any programs that may be using it.
at processing.app.Serial.<init>(Serial.java:144)
at processing.app.Serial.<init>(Serial.java:76)
at processing.app.debug.Uploader.flushSerialBuffer(Uploader.java:73)
at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:83)
at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:55)
at processing.app.Sketch.upload(Sketch.java:1498)
at processing.app.Sketch.exportApplet(Sketch.java:1465)
at processing.app.Sketch.exportApplet(Sketch.java:1420)
at processing.app.Editor$48.run(Editor.java:2235)
at java.lang.Thread.run(Thread.java:619)"

Moi être perdu ! c'est frustrant!
teriak
 
Messages: 4
Inscription: Mer 26 Déc 2012 15:11

Re: Starter kit chapitre 0

Message non lude teriak » Mer 26 Déc 2012 19:19

ouahhhhhh!!!! merci billscott59!
Voici le lien http://forum.snootlab.com/viewtopic.php?f=18&t=61de la page qui m'a sauvé après plus de 2 heures de recherches infructueuses et d'essais divers, j'ai enfin pu m'initier aux 2 premiers chapitres!!!!
teriak
 
Messages: 4
Inscription: Mer 26 Déc 2012 15:11

Re: Starter kit chapitre 0

Message non lude Philippe_ph » Dim 28 Avr 2013 18:22

panpan a écrit:Bonjour à tous,
c’est mon premier post.
merci pour ces petites leçons.
J’adore commencer par des cas pratiques.

J’ai trouvé dommage que le montage ne soit plus explicite. autant l’AOP est assez simple à monter, autant les branchements du potentiomètre sont assez flous sur le schéma, et pas facile à comprendre pour un débutant, qui a tendance à avoir peur de tout faire griller !! peut-être que des photos peuvent dédramatiser la situation !!

étant donné que j'y suis quand même arrivé !!
je vous montre une photo. ça aidera peut-être quelqu'un, on ne sait jamais.



Bonjour panpan,

Je suis tout à fait dans le cas que tu décris "un débutant". C'est une très bonne idée d'avoir mis une photo car j'ai encore du mal à déchiffrer les schémas électriques. En revanche je ne comprends pas comment tu as branché les fils sur le potentiomètre. Dans mon starter kit je n'ai que des fils mâle-mâle (je ne sais pas si c'est le bon terme mais en gros il y a un pic de chaque côté du fil) et sur ta photo j'ai l'impression que tu as utilisé des connecteurs femelle. Est-ce que c'est bien le cas ? J'ai essayé de brancher directement le potentiomètre sur la breadboard mais il y a 4 pattes métalliques qui me gênent. J'ai aussi essayé de brancher mes fils mâle-mâle sur les petits trous qui se trouvent à côté des chiffres 1, 2 et 3 mais ces trous sont trop petits.
Merci pour ton aide en tout cas.

Philippe.
Philippe_ph
 
Messages: 4
Inscription: Mer 31 Oct 2012 09:12

Re: Starter kit chapitre 0

Message non lude matthieu1234 » Sam 3 Aoû 2013 13:11

Ne connaissant rien à l'électronique, le chapitre 0 pour le starter kit Snootlab me paraît un bon point de départ pour la réalisation d'un premier montage. J'avais commencé à utiliser des câbles crocodiles sur le potentiomètre, mais il est possible de le fixer à une plaque en diagonale sans rien tordre, et tout cela paraît plus propre avec des pièces d'autres kits (câbles plats).
Mais un montage, aussi simple soit-il, peut générer beaucoup de questions à un débutant: pourquoi la pin n°3 du potentiomètre est optionnelle, comment tester un LM358N, quelle conséquence si une résistance plus forte/moins forte est utilisée.
Le plus difficile est semble-t-il de comprendre le fonctionnement réel d'un montage et chacun de ses composants, c'est à dire répondre au "pourquoi?" (ex. pourquoi les pin n°1 et n°2 du LM358N sont reliées).
N'hésitez à partager les bonnes ressources (sites, livres...) qui peuvent aider les absolus débutants :mrgreen: .

Montage
http://i.imgur.com/B8r6Qlz.png
Fichiers joints
P8030175.png
P8030175.png (615.82 Kio) Vu 3760 fois
matthieu1234
 
Messages: 1
Inscription: Mer 24 Juil 2013 23:31

Re: Starter kit chapitre 0

Message non lude robby » Jeu 5 Déc 2013 18:25

Je viens de réessayer ce montage car je voudrai comprendre pour un autre projet. Ce que je vois:
1. le schémas de la mise en œuvre sur la mise en œuvre n'est pas explicite pour un débutant: il faut comprendre les connectiques (2 d'un côté un de l'autre).
2. La résistance sur vos réalisations passent d'un côté à l'autre du breadboard, ce qui n'est pas le cas sur le schémas fritzing...
robby
 
Messages: 3
Inscription: Lun 29 Oct 2012 12:56


Retourner vers Starter Kit

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité