Configuration XN-RV dans le setup du Sketch Arduino

Informations et questions sur les composants tiers de la boutique (émetteur/récepteur RF, capteurs...)

Configuration XN-RV dans le setup du Sketch Arduino

Message non lude ewok2 » Sam 8 Mar 2014 21:14

Bonjour
J'ai essayé de suivre le tuto :
[TUTORIEL] Module Wifi Roving Networks RN-XV

pour la partie config du RN-XV par ligne de commande j'ai fini par reussir a avoir la connexion
Le ping de mon adresse IP fonctionne

Par contre quand je charge un sketch :
par exemple celui la
Code: Tout sélectionner
#include <SPI.h>
#include <WiFly.h>

void setup() {
  Serial.begin(9600);
  WiFly.setUart(&Serial);
 
  WiFly.begin();
 
  Serial.print("IP: ");
  Serial.println(WiFly.ip());
}

void loop() {

}


J'ai comme reponse dans le terminal :
Code: Tout sélectionner
$$$

ver

5 fois de suite et aucune info de l'adresse IP "Serial.println(WiFly.ip());"

PS : j'ai essayé avec le sketch qui fait le join ssid passphrase et ca donne pareil ..

Une idee ?

Merci
ewok2
 
Messages: 4
Inscription: Jeu 27 Fév 2014 21:32

Re: Configuration XN-RV dans le setup du Sketch Arduino

Message non lude ewok2 » Dim 30 Mar 2014 15:18

La suite :

Apparement je boucle dans le WiFly.begin()
Il fait 4 reboot soft après chaque $$$, ver
Et au 4eme il réussit pas le reboot

Avec les logs il semble qu'il reçoit rien dans "findInResponse"
Comme si la carte Arduino ne recevait rien du module Wifi (Qui est bien connecté au reseau et qui repond au ping)

Une idee ?
ewok2
 
Messages: 4
Inscription: Jeu 27 Fév 2014 21:32

Re: Configuration XN-RV dans le setup du Sketch Arduino

Message non lude ewok2 » Mar 15 Avr 2014 20:50

Petit Up ?

J'ai tenté la librairie WiFlyHQ mais celle ci ne compile pas...
Il y a un conflit avec la declaration prog_char d'un fichier .h de arduino.
Dans le WiFlyHQ elle est en const et pas dans la librairie arduino de base ???
ewok2
 
Messages: 4
Inscription: Jeu 27 Fév 2014 21:32

Re: Configuration XN-RV dans le setup du Sketch Arduino

Message non lude zjk » Mar 12 Aoû 2014 17:37

Hello, as tu trouvé une solution ?
J'ai le même problème...

@+
zjk
 
Messages: 2
Inscription: Mar 12 Aoû 2014 17:36

Re: Configuration XN-RV dans le setup du Sketch Arduino

Message non lude fred » Ven 22 Aoû 2014 11:34

Tutoriel mis à jour et testé (IDE 1.0.5 et Arduino Uno R3 et RN-XV v3, Freebox revolution et point d'accès Ubiquity).

Faites gaffe aux paramètres de la console pour la commande $$$ (9600 bauds, Pas de fin de ligne) et les commandes join, set, etc.. (9600 bauds, NL&CR).

Ne mettez pas les caractères < et > dans le ssid ou le mot de passe.
Exemple : si le ssid du réseau est MaMaison, tapez MaMaison et non <MaMaison>
Avatar de l’utilisateur
fred
 
Messages: 213
Inscription: Lun 20 Déc 2010 15:32
Localisation: Toulouse

Re: Configuration XN-RV dans le setup du Sketch Arduino

Message non lude jmb » Ven 3 Avr 2015 15:57

bonjour

j'ai le même problème également
retour de console $$$ ver

j'ai suivi le tuto cité ci dessus mais pas de changement.
Avez vous trouvez la solution?
jmb
 
Messages: 11
Inscription: Jeu 26 Mar 2015 20:57


Retourner vers Composants tiers

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités