Recepteur 434 Mhz defectueux ?

Informations et questions sur les composants tiers de la boutique (émetteur/récepteur RF, capteurs...)

Recepteur 434 Mhz defectueux ?

Message non lude Cerghan » Ven 31 Juil 2015 16:23

Bonjour,

j'ai commandé sur le site un émetteur et un récepteur 434 Mhz afin de réaliser un projet de "porte clefs siffleur". J'utilise un ATtiny85 dans chaque partie (émission et réception). Je me suis basé sur ce tuto présent également sur le forum pour la partie transmission de données:
viewtopic.php?f=18&t=875&p=4333&hilit=ATTINY+433

Cependant, si j'observe bien une activité coté émetteur (la led entre le data et gnd clignote bien lorsque j'envoie des données), je n'observe quasiment aucune réaction coté réception. La patte data du récepteur est environ à 2,4V et varie légèrement, est-ce normal ?
J'ai essayé de mettre une led entre la patte data du récepteur et gnd mais à part effondrer la tension de sortie je n'obtiens rien à part un très léger clignotement de la led lorsqu'il y a émission. Même en appliquant à la lettre le tuto, je n'ai pas le même résultat. Est-ce que vous auriez un moyen de tester ce récepteur qui me parait à présent suspect ? Ou une idée pour me débloquer ?

Merci !
Cerghan
 
Messages: 1
Inscription: Ven 31 Juil 2015 16:10

Re: Recepteur 434 Mhz defectueux ?

Message non lude Laetitia » Mar 4 Aoû 2015 18:47

Bonjour,

Cerghan a écrit:La patte data du récepteur est environ à 2,4V et varie légèrement, est-ce normal ?

Normalement un état "bas" sur la ligne Data du récepteur correspond à une tension de 0 à 1.5V, et un état haut à une tension de 3.5 à 5V (pour une alimentation en +5V).

Cerghan a écrit:J'ai essayé de mettre une led entre la patte data du récepteur et gnd mais à part effondrer la tension de sortie je n'obtiens rien à part un très léger clignotement de la led lorsqu'il y a émission.

Si vous mettez une LED "témoin" sur la pin Data du récepteur, il faut penser à mettre une résistance en série avec celle-ci. Excellent réflexe cela dit, pour vérifier visuellement l'activité sur la ligne ;)

J'ai repris le tuto tel quel, câblage et code à l'identique, avec plusieurs récepteurs neufs, et j'ai exactement le même bug. Qui se reproduit même en changeant de sketch, de librairie, etc. Je continue d'investiguer, je reviens vers vous dès que j'ai du neuf :)
"If it's itchy, scratch it !" - "DIY or die"

RTFM (À lire avant de poster) - ANDb (Arduino Noob Database)
Avatar de l’utilisateur
Laetitia
 
Messages: 296
Inscription: Mar 7 Aoû 2012 15:07
Localisation: Toulouse

Re: Recepteur 434 Mhz defectueux ?

Message non lude Laetitia » Mer 5 Aoû 2015 16:26

Bonjour,

Laetitia a écrit:Si vous mettez une LED "témoin" sur la pin Data du récepteur, il faut penser à mettre une résistance en série avec celle-ci. Excellent réflexe cela dit, pour vérifier visuellement l'activité sur la ligne ;)

Après vérification, le récepteur ne délivre pas assez de courant pour allumer la LED directement. Pour le tester, je vous propose la méthode suivante :
- Branchez la ligne Data du récepteur sur une entrée analogique de l'Arduino (A0 par exemple)
- Branchez une LED sur une sortie PWM de l'Arduino (D3 par exemple), n'oubliez pas la résistance
- Envoyez la valeur image de la tension reçue sur l'entrée analogique sur la LED en ayant pris soin de la recalibrer :

Code: Tout sélectionner
int val = analogRead(DATA);
val = map(val, 0, 1023, 0, 255);
analogWrite(LED, val);

Il semblerait que la réception soit meilleure lorsque le récepteur est alimenté en 3.3V et non en 5V. Vous pouvez également ajouter un condensateur entre l'antenne et la masse pour limiter les parasites :

Condensateur_antenne.jpg
Condensateur_antenne.jpg (6.33 Kio) Vu 858 fois

Avec ces nouveaux éléments, vous devriez être en mesure de déterminer si le récepteur fonctionne correctement.

Le sketch fonctionne parfaitement sur Arduino Uno (en prenant soin de changer le numéro des pins utilisées), si le récepteur est fonctionnel c'est qu'il y a un souci au niveau de l'ATtiny. Je continue mes recherches :geek:
"If it's itchy, scratch it !" - "DIY or die"

RTFM (À lire avant de poster) - ANDb (Arduino Noob Database)
Avatar de l’utilisateur
Laetitia
 
Messages: 296
Inscription: Mar 7 Aoû 2012 15:07
Localisation: Toulouse


Retourner vers Composants tiers

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité

cron