raspberry pi

Carte pilote en Pwm sur bus I2C

raspberry pi

Message non lude carvals » Lun 7 Jan 2013 00:42

Bonjour,

Je prépare une petite appli pour gérer l'éclairage via une interface web. J'ai quelques questions avant de faire n'importe quoi car pour la partie soft c'est OK mais je débute en hardware.
Pour le matos:
R-PI
PWM driver
Power MOSFET
ruban led (blanc + RGB)
Alim pour led 12V


1: Si j'ai compris il faut amener deux sources de courant differentes 5V pour la board et les pwm et 3.3V pour le MAX7313
2: Si 1 OK alors: sur la board il y a un connecteur HE10 qui doit amener les 5V pour la board puis les SDA / SCL / 3.3V de l'I2C. Il ne semble pas y avoir (sur les photos) de numerotation des pins (comme pour l'autre connecteur) est il possible de savoir ou sont les 1 et 10.

D'avance merci!!!

carvals
carvals
 
Messages: 4
Inscription: Dim 6 Jan 2013 18:48

Re: raspberry pi

Message non lude carvals » Lun 7 Jan 2013 12:24

Bonjour,

j'ai peut etre repondu a ma question...
dans le diagramme "topside" le triangle indique le pin 1??

desole je ne sais pas bien lire ces diagrammes...

merci


carvals
Fichiers joints
pwm.JPG
pwm.JPG (35.38 Kio) Vu 4171 fois
carvals
 
Messages: 4
Inscription: Dim 6 Jan 2013 18:48

Re: raspberry pi

Message non lude Lionel » Lun 7 Jan 2013 14:14

Ca indique le 1 sur la nappe, mais c'est a coté du pin 1 aussi

Image
Image - Distributeur officiel Arduino - Conception de shields
Avatar de l’utilisateur
Lionel
 
Messages: 734
Inscription: Mar 21 Déc 2010 09:52
Localisation: Toulouse

Re: raspberry pi

Message non lude carvals » Lun 7 Jan 2013 16:09

super merci.

Je ne vais pas utiliser la nappe mais directement une breadboard puis vers le R-PI, cela aurait été dommage de mettre le 5V dans le 3.3V ... juste par ignorance.

encore merci
carvals
 
Messages: 4
Inscription: Dim 6 Jan 2013 18:48

Re: raspberry pi

Message non lude carvals » Mar 8 Jan 2013 00:53

Bonjour,

encore une question... j'ai tout connecté
et avec le code suivant

import smbus
import time

bus = smbus.SMBus(1)
bus.write_byte_data(0x55, 0x14, 0xff)
print read_byte_data(0x55, 0x14))

J'obtiens 255
et meme manip avec 0x00 a la place j'obtiens 0, avec 0x22 --> 34 etc...

Donc le MAX répond en revanche coté LED rien... anode connecté sur pin 20 (5V) et cathode sur le pin 1.
J'ai testé tous les pins en PWM et rien donc fatalement j'ai du raté quelques choses
Si je ramene l'anode sur le pin 19 ou 9 ca fonctionne...

merci pour votre aide....

UPDATE-----Bon j'ai tout deconnecte recabler et relancer et ca fonctionne, j'avais peut etre fait une erreure dans le set up ou le cablage-----UPDATE
carvals
 
Messages: 4
Inscription: Dim 6 Jan 2013 18:48


Retourner vers Driver I2C Pwm

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

cron